CPDev - FBD programming
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Introduction

CPDev environment supports programming in graphic FBD language (Function Block Diagram)
by means of FBD editor module (external component). Users can create all POU types (pro-
grams, functions and function blocks) and trace values of variables during simulation. In this in-
struction creating a typical program in FBD language involving input/output variables, functions
and function blocks is described in details. Creating user-defined function and function block is
also presented. Other examples are also provided, such as common switching circuits, low/high
alarms, time measurement and signal filter. It is assumed that the user is familiar with basics of
using CPDev environment.

START-STOP diagram

Diagram elements

» Final program in FBD language is shown below. It contains:
- input variables START, STOP, ALARM
- output variables MOTOR, PUMP
- functions OR, AND
— instances DELAY_ON, DELAY_ OFF of function blocks TON, TOF
- constants T#5s, T#10s
- comments.

P e e e . ~ The program turns on /offa MOTOR and a PUMP
"""" — . : * | The MOTOR is turned on immediately after pressing | °
I_ ___________ . . | START and turned OFF after pressing STOP or i
G e - | when ALARM appears. The PUMP is turned on
" ' 1 3 seconds after the MOTOR and turned off
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» Execution order of functions and function blocks is specified by numbers 1, 2, 3, 4 written in-
side rectangles.

» Main part of this instruction describes how to create and simulate such program. Other exam-
ples are presented later.



New program

» New project is defined by selecting File = New in CPDev main menu or clicking New icon in

View Project Tools Window Help

Ctri+N Q - | En bg )

Project
the toolbar.
I CPDev
| File | Edit
| New
5 Open

Cirl+0 —i I

» Enter Project name, here Start_Stop_FBD, and eventually other data in Project properties

window.

Project properties
Basic Advanced
General

Project name:

File location:

Information

[] Subject

[ Version

[ Author

[[] Company
[ Created
Compiled

] Auto number:

VM specification:

[Start_Stop_FBD

|C-\Program Files (x86)\CP DevFBD-1.1.4.15d\VM\VM-Prauds xml

|ngram tums motor and pump on and off

|v.l

I.}an Nowak

|Rz&510w University of Technology|

| Tuesday. February 06. 2018 10:13:35 AM

[Monday, January 01, 0001 12:00:00 AM

[

==

» File location, compilation date and auto number will be filled in
automatically while saving the project.
VM specification indicates path to virtual machine description file.
o Left part of CPDev window presents initial tree of the

Start_Stop_FBD project.

Program name, POU type and language

* Program can be added to the project in two ways:

- from project tree:

o select project name, i.e. Start_Stop_FBD
o from context menu, select Add ltem > Program or select POU and from its context
menu choose Add - Program

— from CPDev main menu:

o select Project

J® CPDev
File Edit View Project

DS HGE L E]

R Start_Stop_FBD
L {g POU

{1 Global vanables
{5y Tasks

& Librares

o from drop-down menu, select lfem - Add and select Program in Adding new element

window.



» Enter Object name, here START_STOP, and choose FBD language (default FBD editor ap-

pears).
8 Creating new POU - O 4
Object type: | Program v|
Object name: |START_STOP |
Source language: |FBD V|
Edtor: | FBD editor v

| Coed

* In this window the user can also select another object type,
namely function or function block.

Start_Stop_FBD
=& POU

» Project tree involves now START_STOP program. . START_STOP

FBD graphic editor

Tree

» Left part of FBD editor window contains tree whose elements can be dragged or selected and

{2 Giobal variables
i#-{5 Libraries

dropped on the drawing board on the right.

t| {5 Functons
H-{F System blocks
i-{i Basic_biocks
iy 1EC_s113

Frrn A B rom P




» Grey line farther to the right (move scrollbar or maximize) is the limit of first printed page. Grey
lines partition total work area into a few pages (see Printing).
» The tree involves:
- input/output variables, constant and comment
- afew frequently used blocks and functions
— Functions branch with subbranches, such as arithmetic ADD, SUB, ..., logic AND, OR, ...,
conversions INT_TO_REAL, ..., etc.
— hardware dependent System_blocks (see below)
— blocks of standard IEC_61131 library
— blocks of Basic blocks library with special arithmetic blocks, switches, memory blocks,
comparator, flip-flops, pulsers, filters, and some nonlinearities (see basic CPDev instruc-
tion).

Remark. Hardware dependent System blocks such as NV_PAR_... store parameters in
nonvolatile memory (BOOL, INT, REAL, TIME). aPON and aSTR raise alarms, i.e. alarm
power-on (“warm” restart) and alarm start (“cold”).

=4y Functions =i-iay |EC_&1131 oy Basic_blocks
+-{& ADD. SUB, T cro T AMEM
1) AND, OR, I cru {1 Aswi
-5 INT_TO REAL, 7 cruo {7 smem
+-{&y ABS,SORT, {T =mRic I sswi
{5 GT,LE.NE, { =_mric { come
#-{E5r ROL.SHR. {TT == {% pesa
-5y SEL LIMIT, {7 sema { oets
#-{& RTC. CYCLE, {7 =m {% orr
44 HOUR, DAY, ﬂ TOF ﬂ DIFR
#1557 ROUND, TRUNC, {7 Ton {T omw
{5 NV PAR B, T {* FT
Hy Unctassified ﬂ GENR
Find element
» Expanding the tree to find rarely used function or function SEL K ¢

block could be cumbersome. To make it easier, user can

. . . L Varables and constants
simply write a part of name in the text box above the tree to

Ly Frequently used

trigger automatic filtering of elements. 3-{&5 Functons

» Function subbranches and/or libraries with elements includ- =& SEL.LIMIT,
ing the written text are presented. For example, after typing fz) LMmIT
SEL corresponding function appears in the tree. Another ). MAX
text may result in a few elements. : :J:

Vel



Editor options

FBD editor ; Project Tools Window  Help

o Verify ta &
Change order
| View » | HE  Show lines
Advanced mode [j Show grid
) Scale > 200%
Show/hide elements tree F2 |
qﬂ
Show ST code of diagram F3 =0
[¥] 100%
Use last selected element from tree  F4 —]
) 20%
50%
Manual

» The following options are available in FBD editor menu:

Verify — checks diagram completeness (elements, connections, etc.)

Change order — changes execution order of all successive elements (or preceding)
View — contains options of diagram presentation:

o Show lines — switches on/off supplementary lines on the diagram

o Show grid — switches on/off grid and grey lines on the diagram

o Scale — chooses scale ratio

Advanced mode — switches on/off advanced mode, where some extra functions and blocks
are available (and visible in the tree)

Show/hide elements tree F2

Show ST code of diagram F3 (after Build)

Use last selected element from tree F4.

Development steps

Global variables ' Start_Stop_FBD
» Global variables are usually declared at the beginning of f s gﬂt’al osiciien
creating the project (see basic CPDev instruction). ; ‘f S START

» Declared global variables shown in the project tree are +| e STOP
included into hint list. (- o ALARM
» The list appears in Variable properties window (see below). il ;‘UO;E'R
(4 .
7 Tasks

f#-iy Libranes

Diagram

» Place all elements on the drawing board at locations corresponding to processing order. Tem-
porary names are given automatically. Leave sufficient space between the elements for con-
nections.

» Make eventual adjustments of original locations. Take printing into account. Careful initial
planning limits later corrections considerably.

» Change temporary names of:

— input/output variables into names of global variables and target names of local variables
— function block instances into target names.
» Write in values and types of constants.



» Create connections between inputs and outputs, preferably in the following steps:
short connections between constants, parameters and inputs of corresponding blocks

connections between adjacent blocks
connections between remaining blocks
branch points and relevant connections
connections to external inputs and outputs.

» Check execution order of functions and function blocks.
» Verify FBD diagram (editor option).

Task. Compilation. Simulation

» Declare task, select cycle and assign program (programs) to the task.

» During compilation the open diagram is verified again and the whole project translated into ST
language. If the ST translation does not have errors, it is compiled into VMASM code of virtual
machine.

» Online operating mode and CPSim simulator provide tracing of variable values during execu-
tion.

Elements of START-STOP

Placing elements on the diagram

» To place element on the diagram:

select the element in the tree on the left
drag it to the target location (or select and drop).

Execution numbers are automatically selected while placing elements on the diagram.
+ To move element:

select it

— press and hold left mouse button and move the cursor to new location

release the button.

Remark. Element cannot be moved into new place if there is not enough room. It is shown
in red and returns to previous place after releasing the button.
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» To remove element:
- select it (becomes gray)



- press Delete key or right-click, select Delete in the window and left-click.

Input, output and global variables

» Variable properties window allows to change name of variable from temporary name such as
input1 or output1 given automatically. To open the window, double-click the variable or se-
lect it and choose Properties option from context menu.

 If the project has been rebuilt after declaration of global variables, pressing the ellipsis button
(...) or F2 opens the new Global variable selection window where the user can choose the var-
iable without typing. The choice is confirmed by pressing Enter, Escape or closing the window.

[ e [[mpal | Global variable selection B
ol j o MISTART (BOOL)]
©  Name: Ilnpun € 3 STOP (BOOL)
' ' L " " Name:| ALARM (BOOL) ]
| Type:  [BOOL & ‘ o | MOTOR (BOOL)
- i ' ‘ Type: | pUMP (BOOL) |
.. Version: Local variable Visriod
|STAP"']—':::“::‘-:::::::‘-:H::::'— . "
. .B . Variable input1 properties n:
©° Name: [START D : © 7 Name: |s
© " Type: BOOL © 1 Type: START
.. Version: Global variable i " Version: | STOP

Variable properties window also provides hame prompting functionality as an alternative to
the ellipsis button or F2. This may be convenient for long global variable list.
» Variables with names other than in the global variable list automatically become local.

Remark. CPDev compiler does not distinguish lower-case and upper-case characters. So
for instance name1 and NAME1 denote the same variable.

» To close Variable properties window, press

.  [STa : - {moToR | -
Enter, Escape or closing button. : . : :
sk e ]
ALARM |- - -
Functions
* Number of inputs of some functions can be select-
ed as follows: " lanp |
— open Function properties window (double-click the : 5 | Function AND properties [ ]
function) .. .

. : : . 11
— choose suitable number of inputs (2 + 15). R

* Number of inputs can also be incremented or decre-
mented by selecting the function on the diagram and - - - - - - Mmbercims
pressing ] or [ bracket keys (+1 or -1). R e

» To change execution order:

- choose suitable execution number in Functions properties window.

' ' Execution number: 2

4 4



» Type of function inputs matches type of out-
put while making first connection. Available = 7| anp
types are shown in tooltip. ,

Function blocks
» While placing function block on the diagram a temporary instance name appears above the

block.
+ Double-click the block to change temporary name DELAY ON - - - - - - DELAY_OFF

in Block properties window. oo I
» Block width is updated automatically every time when

length of the name is changed. Name: [DELAY_OFF | -
« Block properties window also allows to change execu- L= [ror ‘ ‘| |

tion order. B | — = |.
Constants

== | il |

» Double-click the empty rectangle (rounded) to en- :T_"f‘ Coskant properties [~ ]

ter value and type in Constant properties window. L | E

. : © o Value: [Tersel |

Type may be prompted automatically according to ;

value. Type: |TIME v |
Input/output negation

» Right-click particular input or output of function or function block to negate it . 4
(boolean signals only). . 2

Change order of elements

» Making room for new elements inside sequence of execution numbers of already existing ele-
ments is common application of Change order option of FBD editor. For example, if new ele-
ment should be executed as 3™, then execution numbers of all existing elements starting from
3 must be increased by 1.

Change ordering of elements s
Change execution numbers of all elements starting from

an element with number [3 by adding

Cancel I Execute ]

Comments

» After adding a comment to the diagram, double-click the empty rectangle. The window, where
content can be defined, is presented.



| The program turns on /off 8 MOTOR and a PUMP The MOTOR is turned |
{.on immediately . |
.. . . Comment properties n

"""" © " Comment content:

. . . |The programtums on /offa MOTORand || @ . :
.............. a PUMP. The MOTOR is tumed rre
""" <+« + |onimmediately | -

Remark. Comments should be added at the final stage, otherwise their locations would be
taken into account by automatic connections algorithm.

Creating connections

Connection

Connection can be drawn from input to output or from output to input.

» To create connection:
- select or point at the input or output, which will be the beginning of the connection (color
changes to red)
— press left mouse button and drag cursor to the output or input which will be the end of the
connection (while moving the cursor, dashed line from the beginning is drawn)
- release left mouse button, what creates the connection with path calculated and drawn
automatically.
ISTART 1 1 |
NN foror Ll
o RRRRRRRRRRRERIN 1) EEEEEEEEES L
: W‘ _____________ A R R R RERE
B i e e
Llliiiiiiiiiiiioiiiiiiiiiiooc: DELAYON - DELAYOFE oo
_______________________________ TON oo TOF
- —{IN QF——IN Q :
FT ET mhd LN
............................... 3 4 s s+ s & 8 s s s 8 s s
Branch point
* Right-click any place on the connection line to . L ]
add branch point with two tips. “1anp [ * ........ I@ ]

Connection between the branch point and inputof =4 |
an element is done in the same way as between —G

input and output. L



: I RERRRRR v

- [sTOP
- [ALARM

-+ DELAY.ON - DELAY_OFF
TON SRS TOF

For information, type of each input/output of any element is shown in
tooltip after indicating the element’s tip.

Editing

Selection of more than one element:

- select elements with Ctrl key pressed

- alternatively, press left mouse button at any empty place on the diagram and surround the
elements.

Moving:

- with element/elements selected, press and hold left mouse button while moving the cursor
to new location

- release the button.

Remark. Moving an element (or elements) updates connections automatically calculating
relevant paths anew. They may be different than before.

Removing:

— press Delete after selecting element/elements.
Copy and paste:

— select element/elements

- copy (Ctrl+C)

- move cursor to new location

- paste (Ctrl+V).

Tips on automatic connections

Do not make the diagram too tight, since some of the connections may be drawn around.
Undesirably looking connection may be corrected by deleting it temporarily, moving relevant
elements apart and connecting them again.

While moving an element, two different connections originally close to each other may overlap.
Then remove one of them and proceed as above.

Complicated diagram may be split into subdiagrams “connected” by local variables (outputs in
one, inputs in another).

10



Verification

» Choose Verify option from the editor menu. It checks completeness of the diagram (connec-
tions) and consistency of types of inputs and outputs. Results are reported at the bottom of

CPDev window.

FBD editor |
il Verify

3)Disgram verficationstarted. |

\1,) Diagram verifi'n:ation finished |ern:nrsﬁwamnngsﬁ)

» |f FBD-to-ST translation of the verified diagram is of interest, press F3 (see below).

Open diagram is automatically saved every 10 minutes into temporary directory followed by

verification (see Automatic save).

Task and compilation
Task

» Task can be added to the project in two ways:

— from project tree by Tasks > Add task or by Start_Stop_FBD (project name) > Add item

- Task

— from CPDev main menu by Project > Iltem - Add > Task (in Adding new element win-

dow).

» Enter Task name, here TASK_FBD, choose Cycle interval and Executed programs from

Available ones.

Task properties — O > |
Task name: |TASK_FBD \
Task type: (®) Cyclic () As soon as possible
S S
L
Executed programs: Available programs: b
[Start Stop FBD | Start_Stop FBD ; :

Compilation — Build

» By clicking Build icon in the toolbar or selecting Project = Build in the menu the
whole project is first translated into ST language and then compiled into
VMASM code for virtual machine. If errors occur, compilation is stopped. Warn-
ings are reported, however the program can still be compiled. The project may
be eventually saved before compilation (Environment Options - Editing).

» Verification runs automatically before compilation provided that editor window is open.

é) Building the tem "START_STOP". Started at 10:03:35
'é) Compiliation of "START_STOP" completed at 10:03:35.
é) Linking "START_STOP" completed at 10:03:35.

é) Statistics: Errors: 0, Wamings: 0, Hints: 0

Remark. Program may be compiled even without task definition, however a warning

will appear.

11



» ST code of the translated diagram may be shown by pressing F3 (click the diagram first).

Code in ST language n

001 PROGRAM Start_Stop_ FBD

ooz

003 VAR _EXTERNAL

oo4 START: BOOL:

oos STOF: BOOL:

00e ALBRM: BOOL;

o007 MOTCR: BOOL;

oos PUMF: BOOL:

00s END_VAR

0lo

011 VAR

012 ISl ol (* SHIDDENONLINE*)
013 out_andl (iElsssnnAeimiy
014 DELAY ON: TON;

015 out DELAY ON_Q [Ekswwii{esmsiny
0l1€ DELAY OFF: TOEF;

017 out_ DELAY CFF_Q |ig SHIDDENONLINE*)
018 END VAR

0ls

020 out_orl := OR(out_andl, START):

021 out_andl := AND(out orl, NOT STOF, NOT ALARM);

i 022 MOTOR := out_andl;

023 DELAY ON(IN:=cut_andl, PT:=T ,@=>out_DELAY ON_Q):

024 DELAY_ OFF (IN:=out_DELAY ON_Q,PT:=T ,Q=>out_DELAY OFF_Q):
025 PUMP := out_DELAY OFF Q:

02¢

027 END_PROGRAM

: BOOL;
: BOOL;

: BOOL;

: BOOL:;

i

......... L I T — ] L R %

e Local variables with (*$HIDDENONLINE?*) directives created automatically do not appear on
variable value list in online mode.

Online mode

Tracing execution of a project is provided by CPDev online mode. The project may consist of a
number of programs written in the same or different languages. Tracing is particularly convenient
for graphic languages, such as FBD.

Go online
Before going into online mode the project must be built (rebuilt after changes).

e Click Go online icon in the toolbar (becomes framed) or select o B

Project = Go online in the menu. “ &
 The icon indicates that Data sources are set to Simulation. prog
I .

"3"’1 Go online (Simulation) i

FBD diagram online

» CPDev window in online mode involves “live” FBD diagram and list of variable values on the
left. BOOL values are distinguished by continuous (TRUE) or dotted (FALSE) connections.
Values of other types are written above connections, except connections to constants.

12



F CPDev — O %
File Edit View FBDeditor Project Tools Window Help
DEd &8 g v By by B E Global Search @ -

@ |[Glo 8, START_STOP Start_Stop_FED : program (FBD) [online] ==
START_STOP Start_Stop_FB X T S O W Wl R ek T R R 15 2 T O BE G HE 0 U ; A

D e e e e e e e
[ Variable Value BHER Varsbesandcomstants || 11
ISTART FALSE 3 Input varable i’ . P oiw dia o
L
| : o il The program tums on /offa MOTOR and a PUMP.
STOP FALSE -@- Constant * | The MOTOR is turned on immediately after pressing
| ALARM | FaLSE| e Comment START and turned OFF after pressing STOP or
! -1 . | {5y Frequanty used - | when ALARM appears. The PUMP is turned on
MOTOR FALSE ﬁ; ToN 1 | | 19 seconds after the MOTOR and turned off
:PUMP T FALSE‘ % Tor - | 10 seconds after it
|DELAY_ON [lec 611 | i ‘
! Y_{ _i 61 = {2y Functions
| w FALSE By sysembiocks || ooy v e e s JAND [ e B e e
= | 5000 | -y 1EC_81131 £l ; i
| | iy Basc_biocks z fespncaimaings o 3 E EE wa s B g g2 E s
o FALSE p i ; . pex . ¥ ’
| DELAY_OFF IEC_611...| AT WA N UL MM 48 0 B gy gy OELAY.ON
w FALSE MM B GEIEREEE s Loy
[ I 10000 BAnBASEsEELE ibtom L)
a FALSE Sh AeE L8 B ek v 4 nd ALY
Ll 3
.................. L
< >

POU  Resources Types Oniine

» Value may also be shown in tooltip after indicating a connection or tip of element. Type ap-
pears as well if tip is indicated (TIME in milliseconds).

» Change value:

- select input variable S SR o= E
- double-click =7 a e I D D
— enter new value, accept or close the window. L. Setvalue ui
Change is reflected on the value list. R i
TRUE, FALSE may be enteredas 1,0. - |

Constants cannot be changed in online mode.

» |If a few diagrams are open, the one on the top is “live”. It is indicated by [online] after name of
the program.

13



Value list @ [Glo[Bi

» List with values involves variables associated with “live” diagram, START'STOP[)S‘”‘&”‘FB
so global and local variables, and function blocks with in- Variable Value
puts/outputs. If no program is open, global variables are shown on- START FALSE
ly. STOP FALSE

ALARM FALSE

» Change value: Variable Value MOTOR FALSE

- click current value (becomes START [ TRUE PUMP FALSE
blue) ' DELAY_ON IEC_611..

- enter new value, accept. N FALSE
T 5000

* Icons above the list provide: a o FALSE
- start simulation again (if stopped before) DELAY_OFF IEC_611...
— stop simulation temporarily (still in online mode) i FALSE
- show/hide global variables i 10000
- show/hide inputs/outputs of function blocks. g KASE

Stop freezes current values and FBD diagram. Start resumes
online operation.
» The open list is associated with ap- POU  Resources Types  Online

i ] po{ Re T ine
pearing Online tab at the bottom. e o

Clicking POU tab on the left opens project tree, for instance to
choose another program for tracing. Then click Online again.

Data sources

» Clicking Data sources icon shows data sources for online mode,
beginning with Simulation. The second, WinController, is an ad-
vanced CPDev runtime for Windows. Other sources, if shown, rep-

resent specific controllers for which online mode means commis-
sioning.

Data sources b | i Simulator properties X 1
Select cument data source: Resources | Statistics  Options  About
Vitual machine address size bis). 16
Simulation v Properties Memory usage (ytes)
S T | Code: [412 Data: (B2 |
CPDev:-WinController e b
Flash (emulated): [0 Clear
K 1
-~

» Some data of simulated project are shown in Simulator properties window.

CPSim simulator

Another way of tracing variable values during execution is provided by CPSim simulator. It is
more flexible than online mode allowing to assign most important variables to panels with buttons
and “LEDs”, as well as to individual views or custom lists.

» CPSim is run by clicking Run simulator icon in the toolbar or by %‘l[ﬁai?. L[ by 1
selecting Project 2 Run simulator (also Tools = Simulator). —

14



Global variables

» CPSim window presents initially the list of global variables. Execution begins by clicking Start
trace icon or by choosing Trace - Start.

P@ CPSim : Simulation - Start Stop_FBD.dcp o (] x

File Trace View Datasource Tools Window Help

= ._j @ = = W a w 1 | 222 Simulation

iy Start_Stop_FBD

=-mom Global variables Global variables a8
mm START Variable Value
mom STOP
- mm ALARM START | 1
~wom MOTOR STOP
- mrm PUMP AARM | -
-0 Task TASK_FBD |
MOTOR | 1
PUMP \ 1

| (:01:36

» Values of those global variables which are inputs to the program can be changed. More on
CPSim can be found in Help > Programming instruction.

Remark. Values of boolean variables are displayed as 0 (FALSE) and 1 (TRUE).

Control panel

» More convenient way of testing is provided by selecting Group panelicon or by relevant option
in View.

Name: |Start Stop
Panel type
(® Control elements () Variable list

After creating the panel drag and drop on it

varables from the varable tree

» Type name in Panel properties window, accept and drag required variables from simulation
tree on the left into the rectangle panel (which grows accordingly).

START STOP [ x

(o] (o] .

» Test the program by pressing input buttons (BOOL) or by typing values in input cells (other
types).
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Individual view

 Single variable can be traced by dragging it from the tree into DELAY ON.PT x|
view area. Individual views are used for important local varia-
bles and inputs/outputs of function blocks (PT here). Value: | 5000  ms|

Variable list

» By choosing Variable listin Panel properties window a list of variables dragged from the tree is
created. Inputs/outputs of function blocks or local variables used in the diagram (if any) are
usually assigned to such list (which looks the same as the list of global variables).

"% CPSim :: Simulation - Start_Stop_FBD.dcp = O X
File Trace View Datasource Tocls Window Help
= _J Jlj O = » @ mn 229 Simulation
=-{y Stat_Stop_FBD

= Global variables
] glgET Variable Value
.
255 ALARM TRUE
- MOTOR STOP FALSE
e PUMP ALARM FALSE
=B Task TASK_FBD t
= P Program START_STC|| [MOTOR | TRUE
=-{ DELAY_ON FUMP FALSE
wiN
. PT i
aﬂ; a START STOP x|
O ET
=7 DELAY_OFF
o [sroer | [rorer ]
- PT
G50 |
{h ET ==
Value: 5000 ms| | Vae | 2188 ms|
Variable Value
10000
ET 0
< >
I oo:00:04

Sessions

» Lists, panels and views created for simulations can be saved for future use by selecting Trace
- Save session or by yes answer to the question Do you want to save the trace session?
asked on CPSim exit. Session data are saved in the project folder as SCP file.

» Complex project may require a few simulation sessions with different views. Data of each ses-
sion should be saved in separate file and run by Trace > Open session...

User library

User can create his own functions or function blocks and store them in a library (programs can be
stored as well). Two examples are shown below:
 function F_AVERAGE for calculation of average from three REAL inputs
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» function block DELAYED_PULSE for generation of one-cycle impulse after time T since lead-
ing edge appears at the input.

Source project

» Create a new project with suitable name and add two new POUs with appropriate object
types, i.e. function F_AVERAGE and function block DELAYED_PULSE.

» Creating the function and function block in FBD language proceeds in the same way as de-
scribed earlier.

» In case of function block, input variables placed on the diagram are translated into block inputs
and output variables into outputs. Names of the inputs and outputs will be shown while using
the block in this or another project.

* In case of function, input variables are translated into function inputs and output variable with
the same name as function is translated into value returned by the function. As indicated in
IEC 61131-3 standard, names of the inputs will not be shown while using the function (howev-
er, they can be found in the project tree; see below).

- - -+ - Function - F_AVERAGE |

IN1 Div [F_A‘."ERAGE

me_—— Bo J—— 2 |

---------- r_trig1 rs1 ton1
---------- RTRIG |- -- RS ceee [ TON
CLK Q s al N Q {a

» Save source XML project of the library for future extensions and for recompilation in case
when new version of the compiler is installed (see Library warnings).

Export as a library

» To export project as a library:
— choose options Export > Library from Project menu
— in Export project as library window:
o write library name (for instance My _blocks below)
o choose library file location (press ellipsis button (...))
o select POUs exported into library
o press OK.
» Library is saved as LCP file.
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Using the library

Library imported to a project is available in the tree of FBD editor and also shown at the left
part of the main CPDev window. Function blocks and functions stored in it can be used in FBD
diagram.

FBD program shown below tests DELAYED_PULSE and F_AVERAGE. CTU block counts
pulses.

o TESTE
DUITTIIUINTD delayed puised Lo llllilll gy Liiiiiiiiinn
Ll [DELAYED PULSE] L il iliiiii[ew | iioiiiiiiii
e N ol cu  aliiiiiiiiii
bbb ::1@"' R cv|—{count ]

[ﬁ]_r ; T ey |
R 3 SRR
LIl [eReT — | [AvER] iiiiiiiiiiiiin
N Py FAVERAGE | - - - == o
SEEEEEE N X 2 oo

To remind names of F_AVERAGE function inputs one can expand = . ""‘Téc“"’ s
F_AVERAGE in the Libraries section of the main CPDev window. -l My_blocks

-6 F_AVERAGE
LN
g N2
R 5 N k]
i-7 DELAYED_PULSE
Views of sample simulation session for Test My blocks project are shown below. Note that
the last two individual views present input and output of the timer which is a component of us-

er-created function block (third level of hierarchy).

P CPSim :: Simulation - Test_My_blocks.dcp — [ X
File Trace View Datasource Tools Window
‘| O & T Bk a n @ |2simulaton
=-{&F Test_My_blocks ~
=) Global variables Global variables n
e ol Varisble  Value
s FIRST AVER 2
| e INP COUNT 3
=-B7§ Task TASK FIRST
=~ P Program TEST_MY_BLOCK
- mum OUT_F_AVERAGE1 INP
=-{F DELAYED_PULSE1
: g?‘ F_AVERAGE [ = |
By a
@} R_TRIG1
--mm OUT_R_TRIG1_Q
@7 RS1
== OUT_RS1_Q1
= ﬂ;’}‘; TONT.PT
e »
-y ET 2]
-wm OUT TON1 Q v
< >
| I 00:03:17
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Other issues

Changing FBD program name
Program name given initially needs to be changed sometimes in the final version.

» To change program name:
— open the diagram (if closed)
— select the program in the project tree
— choose Project > Items > Rename
— enter new name in the tree
— accept (Enter)
— build and save the project.

Library warnings

When library is linked to a project, CPDev automatically stores library version, timestamp and
number of compiler version which created the library (LCP file). When the project is open again
and built, those markers are compared with markers of actual library and compiler. Inconsisten-
cies trigger warnings.

» The following warning indicates outdated library:

/8 Declared library timestamp ~ date  is not equal to timestamp found in library name  fromfile 'C location

If library content and compiler version have not been changed, ignore the warning and pro-

ceed with the project. Warning will not appear on next opening.

Otherwise:

— remove the library from the project tree by selecting the library and choosing Remove from
context menu

— import actual library into the project by Project > Import > Library from the file indicated by
location.

» New version of CPDev compiler includes recompiled system libraries, i.e. IEC_61131./cp and
Basic_blocks.lcp. However user library, like My _blocks.lcp above, has not been recompiled
yet. Therefore the following warning will appear:

L\, Library name file “"C: location was designed for other compiler than cumently used

» To remove the warning:
— compile source code of the user library with the new compiler
— export it as LCP file into given location
— remove the library (with old timestamp) from the project tree
— import the recompiled library into the project.

Automatic save

» Every 10 minutes (default) CPDev creates a file in temporary directory (see operating sys-
tem settings) called CPDev_ProjectNameOrFileName_EightHexNumbers.xml with source
code of the project. This is a back-up in case of CPDev crash.

» If FBD diagram has been changed within that period, it is automatically verified (if open).

» The automatic save period may be changed in Environment options - Editing
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Examples

Start stop — RS
+ Implementation ~of START e
STOP circuit with RS flip-flop. ::.'L:L::::.'L::::f‘g"ﬁi"i'.g.':"sg'f::::::i‘.:::::
""""""""" - SRR
Start Stop RS x| : : RS R
. ] . e | me
:@f‘ b B R e R

Protection against frequent restarts

After STOP or ALARM (thermic sensor) another restart possible only after time set by
TIME_PROT variable (initially 10s, i.e. 10000ms).

» CPSim: control panels with I/O and time data.
3
Restart protection E2 | protection time E3
B B (] (o] | [ oo [ s
TIME_PROT  ET
Start-up horn
o START turns HORN on for time set by TIME_HORN (10s). Then CONVEYOR begins to move.

CPSim: control panel while HORN is on.
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Start-up horn ﬂ

B =] o [ o

HORN_TIME ET

Blinking light and counter

» LIGHT blinks when IN is on. The two timers implement a pulse generator (oscillator). CTU
counts pulses.
» CPSim: control panel with I/O and individual views.

Blinking light = TONTPT B2 |torz et | x |
[w] Bl ¢ Value: 1000 ms| | vsue | 2000 ms|
COUNT I
Single pushbutton

o First pressing ON_OFF turns
MOTOR on and another turns it
off.

* Implementations with blocks from
IEC 61131 and Basic _blocks li-
braries.

Single pushbutton B

11

[onoe | (I S o
o [TRUE T Q ——{MoToR | -
[oNOFFf———ak  maf
Burglar alarm

e Sensors WIN1 (window), WIN2, DOOR and GARDEN activate ALARM_LIGHT and
ALARM_HORN, provided that SYSTEM_ON is set. HORN_OFF switches off ALARM_HORN
till SYSTEM_ON is reset.
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Burglar alarm u

* Note that if connections are not created in recommended steps (see Tips on automatic con-
nections) the following diagram may result due to automatic calculation of paths.

Low/High alarms

e AL H or AL _L arise when IN_R (RE- L D

AL) violates LEVEL_H (90%) or LEV- - LSREEEERL
EL_H (10%) alarm level. COMPara- OSSOSO ..... . B SR S
tors are set with 1% hysteresis S comp |- - ;

(Basic_blocks).

Low/High alarms | = |

liﬁ aﬁl [en] (<o)

Low/High alarms | % |

Lot [an]
INR
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Time measurement

» Time period Tx is measured when IN is on and indicated as MEAS. TONET shows elapsed
time. SEL latches measured value at the falling edge of IN. INp denotes IN delayed by one cy-
cle.

Time measurement n

0 3130
| ———

TONET

Time measurement n
E] MEAZ: = TONET e
Signal filter

» Two FILTers (Basic_blocks) with feedback connection implement a low-pass Butterworth filter
(damping l/x/E) with time constant T_SEC (REAL, in seconds). Recall that T inputs of the fil-

ters must be \/5 larger, therefore multiplication by 1412.0 and REAL_TO_TIME conversion is
needed.
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Printing

Size adjustment

» Grey lines partition total work area of the editor into printed pages. Final size of the diagram

may be decided before printing to fill in the pages conveniently.

Remark. Diagrams presented above are fairly tight (for consistency). They may be wid-
ened taking into account the grey lines, as the START_STOP printout shown farther.

Page setup

» Choose Tools > Environment options = Configuration - Page setup.

| Projects Editing Colors Miscellaneous Compiler Help Page setup

Border margins
Left {cm): D5 = Right (cm}):

Paper/Orientation

=
tn

Papersize: A4

-

Top (cm) 0.5 4 Bottom (cm):  [0.5 3 (@ Porrit

Draw border Padding (cm): 0.3 = (O Landscape
Draw title block

Title block fields

Subject Company

Project name Project version POU name Author

Filename Date Page number

Update settings upon printing session

Core

Printing scale

- User scale

User scale (%) 100

» Upper part of the options involves Border margins, Paper size, Orientation and Printing scale

(independent of the editor scale).

» Number of pages being printed is determined automatically according to the size of the dia-
gram and printing scale (user selected). Small diagrams need one page, large ones a few.
» Lower part specifies what fields appear in the title block (table) printed at the end of each

page. Table changes somewhat if some fields are not selected.

Subject

|Company:

Project: START_STOP |‘-/ersion‘

|Pcu: Start_Stop_FBD

Author:

File: C:\Users\Leszek Trybus\Documents\CPDev -

programy, instrukcje\Projekty...

Date: 08.02.2018 11:41

|Page: 171

» Data for Subject, Company, Project, Version, Author and File are copied from Project proper-
ties window. Active window determines POU name.

Remark. Options of Page setup are kept in CPDev database (Environment options), so
they apply to each printing till changed.
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Print

» Choose File > Printin the main menu or press Ctrl+P keys or icon in the toolbar (direct print).

» Select printer and preferences in printer selection window. Change of preferences and printout
adjusts grey lines and Page setup options accordingly.

» Press Print.

Remark. Printing to virtual printer such as PDF Creator or Microsoft Print to PDF is conven-
ient way to verify expected printout. Horizontal orientation (landscape) suits FBD usually,
while vertical (portrait) LD and SFC.

AND

g

DELAY_OM DELAY OFF
TON TOF
L N

Q
et —|FT ET FT
3 4
T#I0s

The program fums on/ off 3 MOTOR and 5 PLIMP The MOTOR is fumed jon
mmediately sffer pressing START and fumed OFF after pressing STOP or
when ALARM appears. The PUMP is fumed on 5 seconds affer the MOTOR
_and tumed off 10seconds afterdt 0000000

PUMP

Q
ETL

START_STOP | fan Siop FBD n
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